You are on page 1of 33

2014

Felipe Arellano
León.
Teleccna.cl
05/01/2014
YO SÉ NETWORKING
OSPF
YO SÉ NETWORKING 2014

1
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

ÍNDICE

Proyecto YO SÉ NETWORKING ............................................................................................................ 2
Protocolos de enrutamiento. .......................................................................................................... 3
OSPF .................................................................................................................................................... 4
Métrica ........................................................................................................................................ 4
Paquetes ...................................................................................................................................... 4
Elección de DR ............................................................................................................................. 5
Áreas de OSPF ............................................................................................................................. 6
Tipos de Rutas ............................................................................................................................. 7
Tipos de SLA ................................................................................................................................ 8
Tipos de Áreas ............................................................................................................................. 9
AUTENTIFICACIÓN ..................................................................................................................... 15
VIRTUAL LINK ............................................................................................................................. 19
REDISTRIBUTES .......................................................................................................................... 20
OSPF SOBRE FRAME RELAY ............................................................................................................... 22
Point To Point ................................................................................................................................ 23
Configuración: ........................................................................................................................... 24
Point to Multipoint Con Broadcast (P2PBC) .................................................................................. 25
Configuración: ........................................................................................................................... 26
Point to Multipoint Non Broadcast ............................................................................................... 27
Configuración: ........................................................................................................................... 28
Non Broadcast Multi Access (NBMA) ............................................................................................ 29
Configuración: ........................................................................................................................... 30
Broadcast Multi Access (BCMA) .................................................................................................... 31
Configuración: ........................................................................................................................... 32




YO SÉ NETWORKING 2014

2
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Proyecto YO SÉ NETWORKING

Es un proyecto con el fin de adquirir mayor conocimiento de las tecnologías de networking, así
como explicar de forma detallada información que muchas veces tenemos que buscar en distintas
partes. Buscamos juntarlas todas en este y futuros documentos que realizare.
Realizar aportes para nuestra carrera que muchas veces no son entendidas. Veo este material de
una vista totalmente distinta a la que toman todos los libros o lugares a impartir dichos
contenidos.
No les negaré lo aprendido que también he disfrutado y aprendido fabricando el material.
Los invito a ver NETWORKING de otra perspectiva con el proyecto YO SE NETWORKING.

Felipe Arellano León.













YO SÉ NETWORKING 2014

3
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Protocolos de enrutamiento.

Los protocolos de enrutamiento son una forma de compartir rutas de forma dinámica, así
nos facilitan la vida, bueno es un gran avance ya que no tenemos que configurar las rutas
estáticas en cada Router, además de que si ocurren cambios en la topología estos también
cambiaran sus tablas de enrutamiento.
Los protocolos de enrutamiento se clasifican de dos maneras, por estado de enlace y por
vector distancia.

Protocolos por estado de enlace:
Son cuyos protocolos que conocen la red completa, es decir conocen la topología y sobre
este conocimiento tomas sus decisiones.

Protocolos vector distancia:
Son protocolos que para tomar decisiones de rutas utilizan una métrica en bases a
algoritmos o formulas.

Para este documento nos basaremos en el protocolo estado de enlace llamado OSPF
(Open Shortest Path First), que muchos catalogan como lo mejor para las redes, otros lo
vetan con cierto tipo de topologías por no saber utilizarlo, como por ejemplo Frame Relay.
Mostraremos las 5 formas de configurarlo sobre FR, también tocaremos temas relevantes
de este, como las SLA, la forma de elegir DR y virtual link.











YO SÉ NETWORKING 2014

4
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

OSPF
OSPF es un protocolo de enrutamiento open source, por lo tanto puede ser utilizado por equipos
que no pertenezcan a la marca Cisco, OSPF está normado por la RFC 2327 y 2328. OSPF tiene
muchas ventajas en comparación con otros debido a lo que nos ofrece dicho protocolo, bueno
para empezar siempre nos dicen que OSPF es un protocolo que es de estado de enlace, este sabe
todo lo que está en la red, es decir conoce la topología completa. También OSPF soporta VLSM,
por lo que lo convierte en un protocolo classless y nos permite sumarizar.
OSPF utiliza 2 direcciones para comunicarse entre los Routers, la IP multicast 224.0.0.5 donde
todos los Router conversan y la 224.0.0.6 donde el DR se comunica con el BDR. OSPF utiliza el
Procol number 89.
Para poder decidir las rutas OSPF utiliza un algoritmo con el nombre de DIJKTRA, que por lo más
complicado que se vea en otras partes no es más que la sumarización del costo que le dé a las
rutas, es decir, si un Router tiene para decidir 2 caminos solo tomara el que la suma para llegar al
otro lado sea menor.

Métrica
La fórmula de la métrica (default) es:
(10^8)/BW) [BW en Kbps].

Paquetes
OSPF para interactuar entre si utiliza 5 tipos de paquetes:
-Hello : es un paquete para generar la adyacencia de los equipos, es la presentación de ellos, es
decir, es un HOLA.
-DBD : Data base description, es un paquete que contiene las rutas, mejor aún es el paquete que
contiene la información de la topología.
-LSR : Link state request, es la solicitud de un DBD
- LSU : Link state Update, es la actualización de la base de datos.
- LSA : Link state Acknowledge, es la confirmación para un LSU
Para la adyacencia es necesario como en cualquier protocolo de enrutamiento mantener una
conexión con el vecino e indicarle que sigue ahí, esto lo hace con 2 timers, uno para enviar
YO SÉ NETWORKING 2014

5
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

paquetes Hello y el para esperar que llegue uno, estos pueden ser modificados en cada interface
de los equipos.

Elección de DR
Hay 3 tipos de estados en un segmento Multi-access de las redes con OSPF, el primero es
Designated Router o en su forma abreviada DR, que es el Router que guardará y se encargara de
actualizar las rutas para todos los Router que se encuentran en el segmento, así también existe un
Router de respaldo llamado Backup Designated Router en su forma abreviada BDR, que pasa a ser
el que se encarga del segmento cuando el DR se caiga, algo así como un 2do jefe, y por último
OTHER el que no participa de las negociaciones, según como este configurado este puede pasar a
ser DR o BDR en la medida que se fueran desconectando o cayendo los que ya están con ese
puesto. A diferencia de Spaning-tree aquel que este configurado con una prioridad mayor para ser
DR si llega tarde a la negociación no será DR hasta que no exista una nueva, no será jefe si llego
tarde a la entrevista de trabajo, ya alguien tomo el puesto pese a que él estaba sobre calificado
para eso.
Para la elección del DR, BDR y OTHER, lo hace en el siguiente orden:
 Prioridad más alta
 Router ID más alto
 IP de loopback más alta
 IP de la interfaz física más alta
La configuración de la prioridad y del id se pueden hacer en la interface que está activa con el
protocolo y en la configuración del mismo.




YO SÉ NETWORKING 2014

6
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Áreas de OSPF
OSPF puede tener varias Áreas, que son utilizadas para ir segmentando la red y disminuir la
información para las bases de datos de la red, así también disminuyen la carga de los Router que
las manejan. Hay un concepto que alguna vez me enseñaron y la verdad facilita mucho entender el
diseño de OSPF. Bueno como requisito para las áreas de OSPF es estar conectada a el área 0 o
llamada área backbone, y aquí aplica la “patita de oso”.
ÁREA 0
ÁREA 1
ÁREA 2
ÁREA 3
ÁREA 4

A los Router dentro de OSPF se les asignan nombres según las tareas que realizan en la topología.
-Router interno : todas sus interfaces se encuentran dentro de una misma área.
-Router backbone : 1 ó más de sus interfaces pasan por el área 0.
-ABR : conecta 2 ó más áreas.
-ASBR : conecta a OSPF con otro protocolo de enrutamiento (inyectando rutas).
Un Router puede tener más de una característica sin dejar de ser otra, como por ejemplo un
Router puede ser un ASBR y un ABR al mismo tiempo, o junto con eso estar conectada al área 0 y
ser un Router backbone.




YO SÉ NETWORKING 2014

7
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

R1
R2
R3 R6
R5
R4
EIGRP 100
ÁREA 0
ÁREA 1
Router Interno
Router
interno
Router Interno
Backbone
Router Interno
Backbone
ABR
ASBR

Tipos de Rutas
Para OSPF existen 2 tipos de rutas específicas del protocolo.
E1 : El costo es igual al costo externo más el costo interno (suma costo interno y externo). Se
usa cuando existen múltiples ASBR hacia un sistema autónomo.
E2 : El costo es igual al costo externo, se utiliza cuando existe un ABR hacia el sistema
autónomo (AS).








YO SÉ NETWORKING 2014

8
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Tipos de SLA

LSA tipo 1 (Intra área).
Cada Router genera un LSA para el área al que pertenece, con este LSA el Router se presenta (“yo
soy el Router X”), también describe el estado de la interface conectada al Router. Router Link LSA.
LSA tipo 2 (Intra área).
Network Link LSA, este tipo de LSA sólo las envía el DR con la lista de los Routers conectados a la
red.
LSA tipo 3 (Inter área).
Network Summary Link, el ABR manda la información sumarizada entre áreas, por defecto las LSA
tipo 3 contiene la información de cada una de las subredes definidas en el área de origen.
LSA tipo 4 (Inter área).
AS External ASBR Summary Link, es generado por un ABR sólo cuando existe un ASBR en el área,
un LSA tipo 4 identifica al ASBR y provee una ruta hacia él.
LSA tipo 5 (Inter área [externa]).
External Link LSA, describe rutas externas al sistema autónomo OSPF. Estos son originados por un
ASBR e inunda todo el sistema autónomo.
LSA tipo 7(NSSA External Link).
Es generada por un ASBR que se encuentre en un área de tipo no-so-stuby-área, convierte una LSA
del tipo 5 al tipo 7, esta vuelve a ser del tipo 5 al pasar un ABR.
LSA 1
>Intra área, en tabla de enrutamiento aparece como “O”
LSA 2
LSA 3
>Inter área, en la tabla de enrutamiento aparece como “IAO”
LSA 4
LSA 5 -Inter área (externas), en la tabla de enrutamiento aparece como “O E2”



YO SÉ NETWORKING 2014

9
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Tipos de Áreas
Dentro de OSPF existen 4 tipos de áreas, las cuales poseen características y algunas son utilizadas
para disminuir las rutas de esa área específica.
Para explicar los tipos de áreas utilizaremos la topología propuesta abajo.
R1
R2
R3 R6
R5
R4
STATIC
ÁREA 0
ÁREA 1
Router
interno
Router Interno
Backbone
ABR
10.0.0.0/30
10.0.0.4/30
10.0.1.0/30
10.0.1.4/30
10.0.1.8/30
100.100.100.0/24
ABR
L0 192.168.0.0/24
L1 192.168.1.0/24
L0 192.168.4.0/24
L1 192.168.5.0/24
L0 192.168.2.0/24
L1 192.168.3.0/24
ÁREA 2
Router
interno
ASBR

STUB
Por este tipo de área no circulan LSA´s del tipo 5, es decir, LSA externos. Esta creada para disminuir
la tabla de enrutamiento, junto con esto bajar el procesamiento que tienen los Router debido a las
rutas, este tipo de área crea ruta por defecto de forma automática, es una solución para la
conectividad de los extremos afectados por la conexión.
Lo primordial es ingresar el comando indicando al protocolo de enrutamiento que el área 1 es de
tipo STUB, se realiza en todos los Routers implicados en el área.


YO SÉ NETWORKING 2014

10
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Y la tabla de enrutamiento quedo de la siguiente forma después del STUB.

En el R3 vemos con más detalle el cambio realizado por el tipo de área, ya que en un realizado con
anterioridad “#show ip route” se capturo la ruta OE2.

Después del comando se eliminó la ruta E2 y se agregó una ruta por defecto apuntando hacia el
ABR.
YO SÉ NETWORKING 2014

11
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO




STUB TOTTALY
Por este tipo de área no circulan LSA´s del tipo 3, 4 y 5 inter y External área, por supuesto que
habrá conexión de los Routers más lejanos, ya que este tipo de área también crea una ruta por
defecto apuntando hacia el Router ABR.
Una vez configurada el área STUB, podemos hacer un cambio más para disminuir la tabla de
enrutamiento, ingresamos al ABR e ingresamos seguido de STUB no-Summary.



Veremos que la tabla disminuye de forma considerable en los demás Routers del área.
YO SÉ NETWORKING 2014

12
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO


En la captura anterior podemos ver como cambio el tamaño de la tabla de enrutamiento, además
observamos que ya no circulan LSA´s del tipo 5, 4 y 3. No deja de haber conexión ya que como
existe una ruta por defecto apuntando al ABR, en este caso el ABR pasa a ser una especie de
GATEWAY del área.

NSSA
Es un tipo de área que elimina las LSA´s del tipo 5 del área, pero las convierte en LSA´s del tipo 7,
es decir, cambia una del tipo 5 al tipo 7, al pasar por un ABR esta vuelve a ser una LSA del tipo 5.
Esta área no genera una ruta por defecto de forma automática.
Para la demostración tuve que modificar la topología, inyectando una ruta al protocolo en el área
1, donde aparecerá como una ruta N2.
En rodos los Routers que toquen el área 1 se les configura:
Router(config)#Router ospf 1
Router(config-router)#area 1 nssa
Esto en el router: R1, R2 y R3.
YO SÉ NETWORKING 2014

13
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

R1
R2
R3 R6
R5
R4
STATIC
ÁREA 0
ÁREA 1
Router
interno
Router Interno
Backbone
ABR 10.0.0.0/30
10.0.0.4/30
10.0.1.0/30
10.0.1.4/30
10.0.1.8/30
100.100.100.0/24
ABR
L0 192.168.0.0/24
L1 192.168.1.0/24
L0 192.168.4.0/24
L1 192.168.5.0/24
L0 192.168.2.0/24
L1 192.168.3.0/24
ÁREA 2
Router
interno
ASBR
STATIC
200.0.0.0/24

Al declarar la ruta, dentro del área 1 aparecerá como una ruta N2

Y pasando por el ABR en los Routers pertenecientes a otra área como por ejemplo el área 0 en
nuestra topología vuelve a ser una ruta externa con su LSA correspondiente (tipo 5).

YO SÉ NETWORKING 2014

14
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO


Si nos fijamos en la tabla de enrutamiento del R3 nos falta la ruta “100.100.100.0”. En este tipo de
área no circulan las del tipo 5, por lo tanto no aparecerán las rutas en las tablas, como solución
para este problema es ingresar en el ABR:

Se agregara una ruta por defecto hacia el Router ABR, con esto podemos concluir que el área NSSA
no genera una ruta por defecto de forma automática.


YO SÉ NETWORKING 2014

15
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

NSSA TOTTALY
Este tipo de áreas elimina las LSA del tipo 3, 4, 5, también convierte las LSA´s del tipo 5 al tipo 7, y
genera una ruta por defecto de forma automática hacia el ABR para suplir la conectividad inter
área.
Con la modificación a la topología para explicar NSSA y NSSA TOTTALY, podremos explicar cómo
funciona, bueno primero ingresamos el comendo mágico en nuestro ABR (R1).

Ahora en el área 1 solo circularán las LSA´s del tipo 1, 2 y 7. Como veremos en la tabla de
enrutamiento del Router 3.

El primer punto rojo corresponde a la LSA tipo 7 y el segundo punto rojo corresponde a la
característica especial de este tipo de áreas al crearnos una ruta por defecto de forma automática.


AUTENTIFICACIÓN
-OSPF tiene tres formas de autentificación con sus vecinos:
- Sin autentificación
- Autentificación en texto claro
- Autentificación con hashing
Si los vecinos no comparten la misma autentificación no se podrá establecer adyacencia, por esto
se entiende, como la manera que tiene el Router de asegurar que el vecino realmente es el por
medio de una contraseña.


YO SÉ NETWORKING 2014

16
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

TEXTO CLARO
Como prioridad es configurarlo en las interfaces que se enfrenten, ingresamos a la interface y
digitamos lo siguiente.

Router(config-if)#ip ospf authentication
Router(config-if)#ip ospf authentication-key “password”
Ejemplo: Router(config-if)#ip ospf authentication-key “QWE123”



Captura Paquete wireshark



YO SÉ NETWORKING 2014

17
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Hashing
De esta forma no podremos ver la clave, ya que manda, un hash de esta.
El hash es un algoritmo si vuelta atrás, gracias a esto sería casi imposible que pudiéramos obtener
la clave. Para aterrizar más la idea es como si pesara el tamaño de la clave y solo comparara el
tamaño de la clave mandada con el tamaño de la cave que se supone debería llegar.












YO SÉ NETWORKING 2014

18
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Y la captura de la “pass” cifrada.


TIP´S
Nos podemos ahorrar el ingreso de el comando “ip ospf authentication” para texto claro e “ip ospf
authentication message-digest” ingresándolo en el protocolo de enrutamiento indicando que un
área esta autenticada, esto hará que todas las interfaces que estén en dicha área utilicen
autenticación. La mala noticia es que la clave que vendría siendo el comando “ip ospf
authentication-key XXXXX” e “ip ospf message-digest-key 1 MD5 XXXXX” en cada interface, ya que
podría ser una distinta por cada interface.
Texto claro
Router(config-router)#area x authentication
Texto cifrado
Router(config-router)#area x authentication message-digest
Donde el “x” al costado de “área” indica el número del área implicada.

YO SÉ NETWORKING 2014

19
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

VIRTUAL LINK
En una red no deberían existir, pero si ya ocurrió, un área ha quedado desconectada del área 0.
Recordemos que es necesario que todas las áreas estén conectadas al área 0, para esto, se puede
crear un virtual link haciendo un cable virtual entre el área desconectada con el área 0.
R1
R2
R3 R6
R5
R4
STATIC
ÁREA 0
ÁREA 1
Router Interno
Backbone
ABR 10.0.0.0/30
10.0.0.4/30
10.0.1.0/30
10.0.1.4/30
10.0.1.8/30
100.100.100.0/24
ABR
L0 192.168.0.0/24
L1 192.168.1.0/24
L0 192.168.4.0/24
L1 192.168.5.0/24
L0 192.168.2.0/24
L1 192.168.3.0/24
ÁREA 2
Router
interno
ASBR
STATIC
200.0.0.0/24
VL
ÁREA 5
10.0.0.8/30
V
irtual LIN
K

Primero hay que tener claro que el virtual link tiene que realizarse entre el ABR del área aislada
con el ABR que llega al área 0, en este caso entre el R3 y R1. Y segundo que no puede haber un VL
en áreas de tipo STUB, STUB TOTTALY, NSSA y NSSA TOTTALY.

Router 3 (el ultimo log es de que la conexión virtual levanto).

Router 1
YO SÉ NETWORKING 2014

20
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO


En el primer log nos muestra que está recibiendo una solicitud de VL, y el el segundo una vez que
ya se estableció la adyacencia.
Como veremos en el Router aislado ya tenemos la tabla de enrutamiento completa.


REDISTRIBUTES
Es importante conocer los comandos de redistribución del protocolo, sobre todo cuando este
funciona junto a otro protocolo de enrutamiento.
RIP
Router(config-router)#redistribute rip metric X subnets
EIGRP
Router(config-router)#redistribute eigrp “AS” metric X subnets
STATIC
Router(config-router)#redistribute static metric X subnets
CONECTADAS
Router(config-router)#redistribute connected metric X subnets
YO SÉ NETWORKING 2014

21
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO


En los anteriores, para todos el “metric X” es optativo solo si se le quiere dar un costo distinto para
ser redistribuido.
El “subnets” es CASI obligatorio, bueno si no lo ingresamos solo redistribuirá classless.
AS en EIGRP es el sistema autónomo.

Rutas por defecto
Estas son algo especiales, para OSPF utilizamos un comando que al redistribuir una ruta por
defecto la indicara como una dirección GATEWAY para el protocolo.
Hay 2 comandos para esto con unas pequeñas diferencias, uno crea una ruta por defecto de forma
automática apuntando hacia él y la propaga por la red, y el otro no propagara la ruta a menos que
tenga una configurada de forma manual con un “ip route”
Primera
Es necesario haber configurado una routa estatica por defecto con anterioridad:
Router(config)#ip route “ip” “mask” “int de salida o sgte. Salto” *(Requisito)*
Router(config-router)#default-information originate

Segunda
Esta crea una ruta de forma automática apuntando hacia él y la propaga a la red.
Router(config-router)#default-information originate always





YO SÉ NETWORKING 2014

22
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

OSPF SOBRE FRAME RELAY
Empezaremos las configuraciones para comprender como funciona OSPF sobre Frame Relay, para
ellas utilizaremos la siguiente topología.
SPOKE SPOKE
HUB
S0/0
S0/0 S0/0
S0/1
S0/2
S0/3
DLCI 102 DLCI 103
DLCI 301 DLCI 201
R3 R2
R1
FR
10.0.0.1/29
10.0.0.2/29 10.0.0.3/29



YO SÉ NETWORKING 2014

23
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Point To Point
La configuración más básica, la encontramos cuando las interfaces están como P2P, es decir point-
to-point, como si fueran un cable dedicado para cada conexión con los SPOKE, y se realiza de la
siguiente forma:
Ya levantado FRAME RELAY de forma P2P con interfaces virtuales (recomendación).
OSPF levantara de forma automática al levantar la escucha multicast en la interface (descubre
vecinos), pero no elegirá DR ya que la interface es punto a punto. Esta es una solución CISCO.
Al ser el Network-Type P2P toma como por defecto los timer de los hello´s y los dead en 10 y 40
respectivamente
La explicación de lo anterior lo encontramos en el Network Type de la interface.






YO SÉ NETWORKING 2014

24
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Configuración:

R1
interface Serial0/0
no shutdown
encapsulation frame-relay IETF
clock rate 2000000
frame-relay lmi-type ansi

interface Serial0/0.102 point-to-point
ip address 10.0.0.1 255.255.255.252
frame-relay interface-dlci 102 IETF

interface Serial0/0.103 point-to-point
ip address 10.0.0.5 255.255.255.252
frame-relay interface-dlci 103 IETF

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R2
interface Serial0/0
encapsulation frame-relay IETF
no shutdown
frame-relay lmi-type ansi

interface Serial0/0.201 point-to-point
ip address 10.0.0.2 255.255.255.252
frame-relay interface-dlci 201 IETF

router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.7 area 0

R3
interface Serial0/0
no shutdown
encapsulation frame-relay IETF
frame-relay lmi-type ansi

interface Serial0/0.301 point-to-point
ip address 10.0.0.6 255.255.255.252
frame-relay interface-dlci 301 IETF

router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.7 area 0
YO SÉ NETWORKING 2014

25
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Point to Multipoint Con Broadcast (P2PBC)
Esta forma de configurar esta normada por las RFC-2328, y soporta cualquier topología, el
protocolo de enrutamiento levantara de forma automática, ya que de esta forma si descubrirá
vecinos, pero no elegirá un DR. Los timer serán 30 para los hello´s y 120 para los dead.
FRAME RELAY configurando las interfaces como multi-access conservando el broadcast.



La interface de cualquier Router de la topología hacia la nube FR es:




YO SÉ NETWORKING 2014

26
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Configuración:

R1
interface Serial0/0
ip address 10.0.0.1 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R2
interface Serial0/0
ip address 10.0.0.2 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R3
interface Serial0/0
ip address 10.0.0.3 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0















YO SÉ NETWORKING 2014

27
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Point to Multipoint Non Broadcast
Esta forma de configuración está normada por CISCO, debido a que es sin broadcast esta no
descubre vecinos, y por el network type, no elige DR, soporta cualquier tipo de topología. Los
timer para este tipo de configuración son 30 para los hello´s y 120 para los dead time.



La interface de cualquier Router de la topología hacia la nube FR es:








YO SÉ NETWORKING 2014

28
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Configuración:

R1
interface Serial0/0
ip address 10.0.0.1 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint non-broadcast
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0
neighbor 10.0.0.3
neighbor 10.0.0.2

R2
interface Serial0/0
ip address 10.0.0.2 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 10.0.0.3 201 IETF
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0
neighbor 10.0.0.1

R3
interface Serial0/0
ip address 10.0.0.3 255.255.255.248
encapsulation frame-relay IETF
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 10.0.0.2 301 IETF
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0
neighbor 10.0.0.1






YO SÉ NETWORKING 2014

29
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Non Broadcast Multi Access (NBMA)
Para configurar OSPF de esta forma es necesario recordar que las interfaces de los Router vienen
por defecto como Non-Broadcast Multiaccess, también cómo funciona el protocolo de
enrutamiento, ya que no nos sirve que el DR se encuentre en el HUB porque de esta forma Sí elige
DR, el problema que se nos presenta es ¿Qué pasa si el DR queda en el Spoke?, la respuesta es
fácil no se conocerán ambos spoke´s por medio de las actualizaciones de OSPF, la solución para
esto es obligar a que los SPOKE entren a negociar cambiando la prioridad de la interfaz.
Configurando de esta forma hay que tener en cuenta, que no descubre vecinos, pero que sí elige
DR. Esta normada por la RFC-2328 y que funciona con topologías de tipo Full-Mesh los timer de
este tipo de configuración son de 30 para los hello´s y 120 para los dead.



NETWORK TYPE cualquier Router conectada a la nube FRAME RELAY.



YO SÉ NETWORKING 2014

30
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Configuración:

R1
interface Serial0/0
ip address 10.0.0.1 255.255.255.248
encapsulation frame-relay IETF
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0
neighbor 10.0.0.2
neighbor 10.0.0.3

R2
interface Serial0/0
ip address 10.0.0.2 255.255.255.248
encapsulation frame-relay IETF
ip ospf priority 0
frame-relay map ip 10.0.0.3 201
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R3
interface Serial0/0
ip address 10.0.0.3 255.255.255.248
encapsulation frame-relay IETF
ip ospf priority 0
frame-relay map ip 10.0.0.2 301
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0












YO SÉ NETWORKING 2014

31
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Broadcast Multi Access (BCMA)
Para configurar de esta forma OSPF es necesario cambiar el network type de la interfaz, a
broadcast, ya que como sabemos ya viene por defecto en multi-access , de esta forma si descubre
vecinos y si elige DR, por lo que se nos presenta el problema anterior con el DR, esta es una
solución CISCO, por lo tanto esta normada por ellos, funciona en topologías de tipo Full-Mesh y los
timers son de 10 para los hello´s y de 40 para los dead.






NETWORK TYPE de cualquier interfaz de la topología.

Prioridad para los SPOKE´S

YO SÉ NETWORKING 2014

32
PROTOCOLO DE ENRUTAMIENTO OSPF A FONDO

Configuración:

R1
interface Serial0/0
ip address 10.0.0.1 255.255.255.248
encapsulation frame-relay IETF
ip ospf network broadcast
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R2
interface Serial0/0
ip address 10.0.0.2 255.255.255.248
encapsulation frame-relay IETF
ip ospf network broadcast
ip ospf priority 0
frame-relay map ip 10.0.0.3 201
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0

R3
interface Serial0/0
ip address 10.0.0.3 255.255.255.248
encapsulation frame-relay IETF
ip ospf network broadcast
ip ospf priority 0
frame-relay map ip 10.0.0.2 301
frame-relay lmi-type ansi

router ospf 1
network 10.0.0.0 0.0.0.7 area 0